
How to create a pivot table in Microsoft 
Excel 

This document explains how to start the report from Brilliant, how to import into excel and how to 

create pivot table. 

Occupancy and revenue as pivot table data source 

This report creates a PMPRO_PIVOT.CSV file which contains occupancy and revenue details of each 

reservation in a given time frame. This file can be used as a data source to create a pivot table  in 
Microsoft Excel (2007 or newer recommended), Microsoft PowerPivot or another spreadsheet program 

such as Calc from OpenOffice.org. 
  

A pivot table is a fast and powerful way to analyze data and answer questions you have about it. 

Create a pivot table based on the PMPRO_PIVOT.CSV data source file to analyze your reservation data 
from any angle you desire. For example: 

 Revenue (gross or net, total or per main group) by date, month, quarter, year or day of the 

week. 
 Revenue (gross or net, total or per main group) by market, source, channel or rate code. 

 Revenue (gross or net, total or per main group) by country, state/province, city or zip code. 

 The same as above but for arrivals, departures, room night, persons, reservation lead time. 

 A combination of all of the above. 

 Etc. 

1. How to get here? 

 

 
 Choose Occupancy and revenue as pivot table data source from the Reports » Statistics 

menu. 

 Click the Start button, enter a date range and click the OK button. 

 The reservation data will now be exported. This may take a long time, depending on the date 

range you have specified and the amount of data that must be collected and exported. 

 The data will be saved in the ..\PMS\Output\PMPRO_PIVOT.CSV data source file. 



2. Tips, Tricks & Pitfalls 
 The export can be created for past and future dates. However, in order to include revenue 

data for the future you need to run the forecast interface to update the forecasted revenue 

data. 
 The export contains all room, conference room and dummy room reservations. In order to use 

the export for e.g. bed room statistics, you will need to separate the data from the different 

reservation types. This can be done by using the 'Record Class' field as a report filter or as a 
row label. 

 For each reservation the export file contains a record  for every night of the stay PLUS a 

record for the departure date: a reservation of 1 night will have 2 records, a reservation of 2 
nights will have 3 records, etc. This means you should not summarize the rooms, adults and 

children fields in occupancy statistics. 

 

3. Available options 

 Date: Enter the date range for which you would like to export data. This is the "in house" or 

"revenue" date and unrelated to arrivals or departures. If you enter 1 January to 31 January, 

the export also contains records from arrivals in December who leave in January and records 

from arrivals in January who leave in February. 

 Update forecast: Enable the tickbox to update the revenue forecast figures before the export 

is created. This will update the entire forecast regardless of the entered date range. 

4. Where can I find the PMPRO_PIVOT.CSV data source file?  
The PMPRO_PIVOT.CSV data source file is saved in the \OUTPUT subfolder of the folder in which 

Brilliant PMpro has been installed. The exact location on your network is different from installation to 
installation. Follow the next steps to find the file. 

4.1 Using Windows XP 
1. Right click on the shortcut you normally use to start Brilliant PMpro and choose Properties. 

2. Click on the Find Target button on the Shortcut tab. 

3. Windows Explorer now opens in the Brilliant PMpro installation folder. 
4. Scroll to the top and open the Output folder. 

4.2 Using Windows Vista or Windows 7 
1. Right click on the shortcut you normally use to start Brilliant PMpro and choose Properties. 

2. Click on the Open File Location button on the Shortcut tab. 

3. Windows Explorer now opens in the Brilliant PMpro installation folder. 

4. Scroll to the top and open the Output folder. 
 

Never delete or rename files or folders that are located in the Brilliant PMpro installation folder. 

This results in data loss and may cause Brilliant PMpro to stop working. 

  

http://help.myhotelsoftware.com/pms/bhs/en/interfaces/forecast_interface.htm
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5. How to import PMPRO_PIVOT.CSV data into the current Excel workbook? 

 

Follow the next steps to import the data from the PMPRO_PIVOT.CSV data source file into your 
current workbook. The imported data can then be used to create a pivot table by using the 'Select a 

table or range' option in the 'Create PivotTable' wizard. 
1. Start Microsoft Excel 2007 and open a new document. 

2. Click on the Data tab, then click on the From Text button in the Get External Data group. 

 
3. You are now in the Import Text File screen: 

 Navigate to the ..\PMS\Output folder, select the PMPRO_PIVOT.CSV file and click the 

Import button. 

 
4. You are now in the Text Import Wizard: 

 Step 1 of 3: in the Original data type area, select Delimited and click the Next 

button. 
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 Step 2 of 3: in the Delimiters area, select Comma and deselect all other delimiters. 

Keep the " character as a Text qualifier. Then click the Next button. 

 
 Step 3 of 3: click the Advanced button.  

 
The Advanced Text Import Settings window opens. As a Decimal separator, select the . 

(dot) from the drop down field. As a Thousand separator, select the blank option from the 
drop down field.  

 
Then click the OK button followed by the Finnish button. 



 
5. You are now in the Import Data screen. 

 Keep the Existing worksheet setting. And click the OK button. 

 
6. The data is now imported from the PMPRO_PIVOT.CSV data source file. This may take several 

minutes. 

7. Click on the Insert tab, then click on the PivotTable button to start the 'Create PivotTable' 

wizard. 

 



8. The ‘Create Pivot table’ screen appears. Leave all defaults and click ok

 
9. A blank pivot table is inserted in the upper left corner of the worksheet. On the left you see 

the PivotTable Field List with all fields that are available for us in the pivot table. Click 

outside the pivot table to close the field list and inside the table to open it again. Alternatively, 
click the Field List button on the Options tab in the Show/Hide group. 

 
10. Drag fields from the field list into the areas that are displayed below the field list: 

 Report filter: shows drop down fields above the pivot table to filter on specific data. 

Examples of fields that are especially suitable for this are the 'Is Allotment', 'Is group', 
'Record Class', 'Reservation Status' and the 'Guarantee Status' fields. 

 Row Labels: shows rows by which data will be displayed and summarized in the 

values area. Examples of fields that are especially suitable for this are the 'Market 
Code', 'Source Code', 'Channel Code', 'Country', 'State' fields, but also all available 

date fields. 

 Values: shows the aggregate data in columns. Examples of fields that are especially 

suitable for this are all revenue fields. 
 Column Labels: similar to row labels and used to group and summarize the values. 

Example: 



 
 

In the above example ‘Record class’ and ‘Resevation status’ have been dragged to ‘Filter’ where ‘Hotel’ 
has been selected in ‘ Record class’  and ‘In’ and ‘OUT’ in reservation status. In ‘Row’ ‘date’  has been 

selected and in the drop down next to ‘Row labels’ only January has been selected. In the ‘Column’ 
field ‘Market’ has been selected and in ‘Values’ the ‘Revenue Incl Tax’ has been selected. 

 
7. You can analyze your data in endless ways. Just add more or less fields to the different areas, 

change to order of them in an areas and/or move the fields to a different area and see how 

your data is recalculated. 
More information about pivot tables can be found on the internet on for example: 

 Pivot Tables on Wikipedia 

 Microsoft Excel 2007:  Pivot Table Overview (step by step video instruction) 

 Microsoft Excel 2003: Pivot Table Overview (step by step video instruction) 

 Microsoft PowerPivot 

 

6. How to create an external data connection? 

A data connection is a set of information that describes how to locate, log in, query, and access the 
external data source. It is a very challenging task to create a new data connection that can be used to 

connect a pivot table to an external data source such as the PMPRO_PIVOT.CSV data source file. 

Follow the next steps to download modify and use a default data connection file: 
1. Download the PMPRO_PIVOT_DATA_SOURCE_CONNECTION.ZIP file and unzip the contents 

to your computer. The zip file contains the following two files: 
 PMPRO_PIVOT_DATA_SOURCE_CONNECTION.DSN:the data connection file. This file 

'tells' Microsoft Excel how it needs to connect to the PMPRO_PIVOT.CSV data source 

file. 
 schema.ini: this specifies the format of the PMPRO_PIVOT.CSV data source file. For 

example, it is used to indicate that the file is a comma separated file where the 

decimal separator of all number values is a dot. 

2. Right click the PMPRO_PIVOT_DATA_SOURCE_CONNECTION.DSN file and open it with a text 
editor such as notepad. 

3. The last line contains: 
 DefaultDir=\\YourFileServerName\Brilliant\PMS\Output 

4. Replace the text behind the equal (=) sign with the location of the PMPRO_PIVOT.CSV data 

source file. This is always located in the ..\PMS\Output folder of the Brilliant PMpro installation 

folder. Refer to the 'Where can I find the PMPRO_PIVOT.CSV data source file'. If you do not 
know the correct location, follow the 'Where can I find the PMPRO_PIVOT.CSV data source 

file?' instructions which are provided in the frequently asked questions. 
5. Now move both files to the ..\PMS\Output folder. 
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If you or your colleagues will create pivot tables from different computers, you need to make 
sure that the DefaultDir you specify in the PMPRO_PIVOT_DATA_SOURCE_CONNECTION.DSN 

data connection file is accessible by all users on all computers. It is therefore recommended to 
use an UNC path as indicated in the example in step 3. If you use a 'mapped' drive letter, make 

sure that the same drive mapping exists on all computers. Contact your system administrator for 
more information. 

7. How to refresh imported data? 
When you imported the data from the PMPRO_PIVOT.CSV into the current Excel workbook, that data 

is not automatically updated you create a new PMPRO_PIVOT.CSV data source file by running the 
'Occupancy and revenue as pivot table data source' report again in PMpro. In stead of following all 

import steps again you can simply refresh the data in the workbook. 

Refresh the imported data 
1. Open the worksheet that contains the imported data and select the first column in the first 

line of the imported data. 

2. Click on the Data tab, then click on the Refresh All button. 

3. You are now in the Import Text File screen. 

4. Navigate to the ..\PMS\Output folder, select the PMPRO_PIVOT.CSV file and click the Open 

button. 
5. The data will be refreshed. 

Refresh control properties 
You can also change the refresh control properties to change the Excel refresh behaviour: 

1. Open the worksheet that contains the imported data and select the first column in the first 
line of the imported data. 

2. Click on the Data tab, then click on the Properties button. 

3. You are now in the External Data Range Properties screen. You can change the following 

settings under the Refresh control area. 

4.  

 Prompt for file name on refresh: disable this option so you do not have to re-select 

the data source file each time you refresh the data (as explained in step 10 above). 
 Refresh every .. minutes: enable this option and enter a value to automatically refresh 

the data on a fixed interval. This is not very useful for a occupancy and revenue pivot 

table because the data in the PMPRO_PIVOT.CSV file does not change very often. 
 Refresh data when opening the file: enable this option to automatically refresh the 

imported data each time you open this workbook. 

 Remove data from the external data range before closing: enable this option if you 

want to save the workbook with the query definition but without the external data. 

 


